MIP470 Frequently Asked Questions

PDF Manuals, Data Sheets, and Press Releases can be found in the MPL Documentation area of this homepage.


Question #340: I observe power-up problems or sudden, unmotivated resets of the MIP board during normal operation. It seems to get worse if an additional add-on card is installed and/or the CPU and/or GPU load is increased.
Answer: Chances are that this is a power supply problem. In contrast to the PIP boards, the MIP boards expect their 5V system input voltage to be provided in a "suitable, clean" form, especially relating to short power transients. Please check the following points:

  • make sure there is a low impedance connection between the external power supply and the MIP board (wire length as short as possible / wire cross section as wide as possible).
  • supply 5.25V  instead of 5V to the system.
  • use a better power supply.
  • solder the power supply wires directly to the pads of the power supply connector on the MIP board.


Question #345: I'm having trouble to get an USB device to work with one of your SBC. Either the USB device is not working reliable (or not at all) or the MPL SBC is even being reset if I insert the plug into the USB port or if the device is activated. The same USB device works without problem if I connect it to my laptop/desktop.
Answer: Is the USB device powered from the USB port only (no external power supply is being used)? If yes, your USB device most probably needs more power than it is allowed to do. The USB standard specifies that an USB device must not consume more than 500mA for USB2.0 / 900mA for USB3.0 (even not more than 100mA before being successfully initialized). For all USB peripherals with higher power requirements than the values mentioned above, the use of an external power supply is mandatory.
So please make sure that you use an external power supply or try to find another, standard conforming USB device.

Please note that the use of an "Y" shaped USB cable to "steal" power from a second, unused USB port is NOT a solution!

Question #329: I have attached a PC/104 or PC/104-Plus card to the [PIP | MIP] and I am sure that the card is configured correctly both from the hardware and the software side. Nevertheless the card does not work as expected, but shows erratic behaviour.
Answer: Does the card need +12V, -12V or -5V from the PC104/PC104-Plus bus? If the answer is yes, chances are that the I/O drivers and/or some A/D or D/A circuitry are not properly powered.
By default the [PIP | MIP] does NOT provide the voltages mentioned above on the PC/104 or PC/104-Plus bus.
Please check the corresponding "User Manual" and/or "Technical Reference Manual" for details.
 
 Copyright © 1997-2018 MPL AG Elektronikunternehmen, a member of the HT Holding AG  |  Privacy Statement
MPL on LinkedIn    MPL on twitter    MPL on Google+